0
已解决
王文博
缔造者之神
缔造者之神
2510 换位置3经验值:400
题目描述 Description
某小学将要举办一年一度的运动会,在运动会开始之前校长组织了所有的师生在操场上开一场全体大会。所有学生排成一个m行n列的矩阵,每个学生获得了数量不等的小红花,现在要求让第x行第a列的同学与第x行第b列的同学互换位置,输出换过位置之后的矩阵。
1<=m,n<=100,1<=x,a,b<=min(m,n)
输入描述 Input Description
第一行:五个整数,分别为m,n,x,a,b,1<m,n<100
接下来输入一个m行n列的矩阵
输出描述 Output Description
输出交换后的矩阵
样例输入 Sample Input
5 4 3 3 1 1 2 3 4 4 3 2 1 6 7 8 9 9 8 7 6 4 5 6 7
样例输出 Sample Output
1 2 3 4 4 3 2 1 8 7 6 9 9 8 7 6 4 5 6 7
https://newcourse.codingtang.com/#/problem/problemSub?id=2510
#include <bits/stdc++.h>
using namespace std;
int main()
{
int m,n,x,a,b;
char c[101][101];
cin>>m>>n>>x>>a>>b;
for(int i=1;i<=m;i++)
{
for(int j=1;j<=n;j++)
{
cin>>c[i][j];
}
}
swap(c[x][a],c[x][b]);
for(int i=1;i<=m;i++)
{
for(int j=1;j<=n;j++)
{
cout<<c[i][j]<<" ";
}
cout<<endl;
}
}
哪里错了?