0
已解决
李牧晓
中级天翼
中级天翼
1338 计算多项式的值 经验值:100
题目描述 Description
对于多项式y=a * x * x+b * x+c和给定的a,b,c,x,计算y的值,a,b,c,x都为整数,计算结果范围为0-100000000000。
输入描述 Input Description
输入一行,为四个整数,每两个数之间用空格隔开。
输出描述 Output Description
输出一个整数。
样例输入 Sample Input
3 2 1 2
样例输出 Sample Output
17
代码:
#include<iostream>
using namespace std;
int main()
{
int a,b,c,x,y=0;
cin>>a>>b>>c>>x;
y=a*x*x+b*x+c;
cout<<y;
return 0;
}
0
0
李牧晓
中级天翼
中级天翼
@李宜和
我要2866
然后我再帖子给你悬赏50
行不,就在下面回答
李牧晓在2021-12-11 00:39:52追加了内容
@李宜和
不对啊,样例过不去
只能过2831,不能过2866
0
0
0
王文博
缔造者之神
缔造者之神
long long a,b,c,x;
cin>>a>>b>>c>>x;
unsigned long long int y=a*x*x+b*x+c;
cout<<y;
0
0