中级天翼
5381 判断素数对经验值:800
题目描述 Description
给出两个数字x和y,试判断,x后的第一个素数是否是y。
输入描述 Input Description
一行,两个整数,x y
输出描述 Output Description
如果x后面的第一个素数是y,则输出"yes";否则输出"no",并输出正确的素数,用空格隔开
样例输入 Sample Input
【样例输入1】 7 11 【样例输入2】 7 9
样例输出 Sample Output
【样例输出1】 yes 【样例输出2】 no 11
数据范围及提示 Data Size & Hint
2<=x<=y<=50
武建豪在2021-03-11 21:54:08追加了内容
歪
武建豪在2021-03-11 22:26:37追加了内容
@侯平仄 @李瑞曦 @赵逸凡 @包涵宇 @程祺然 @邓涵睿
武建豪在2021-03-12 18:48:10追加了内容
歪歪歪,悬赏要多少有多少,为什么没人啊
武建豪在2021-03-12 20:48:35追加了内容
歪歪歪
武建豪在2021-03-12 21:55:56追加了内容
#include<iostream>
#include<fstream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
#include <iomanip>
#include<cstdlib>
using namespace std;
int m,x,y;
bool f(int a){
if(a==1) return false;
for(int i=2;i<=sqrt(a);i++){
if(a%i==0) return false;
}
return true;
}
int main()
{
cin>>m;
if(f(m)==y){
cout<<"Yes";
}
else{
cout<<"No";
}
return 0;
}
0分,大伙帮忙看看
武建豪在2021-03-12 22:16:51追加了内容
@鹿雨扬
高级天翼
把主函数里的都改成:
cin>>x>>y;
for(i从x+1开始,到60结束){
判断i是不是素数{
m=i;
跳出循环
}
}
判断m是不是于y相等{
cout<<"yes";
}
else {
cout<<"no"<<" "<<m;
}
资深守护
- #include<bits/stdc++.h>
- using namespace std;
- bool kx(int n){
- if(n==1)
- return false;
- for(int i=2;i<=sqrt(n);i++){
- if(n%i==0) return false;
- }
- return true;
- }
- int main(){
- int x,y;
- cin>>x>>y;
- for(int i=x+1;i<=60;i++){
- if(kx(i)){ if(i==y){
- cout<<"yes";
- return 0;
- }
- else{
- cout<<"no"<<" "<<i;
- return 0;
- }
- }
- }
- return 0;
- }
- 望采纳,祝你AC,我已AC,快采纳,冒死发整段
- (记得发悬赏)(不发也记得采纳)