0
已解决
高舒豪
中级光能
中级光能
4889 数字寻找2经验值:0
题目描述 Description
现在有n~2*n,找到第一个k的倍数,并输出它。如果没找到这个k的倍数,则输出“没找到”;
输入描述 Input Description
一行,输入2个数 n ,k
输出描述 Output Description
输出k的倍数或者输出没找到
样例输入 Sample Input
15 17
样例输出 Sample Output
17
数据范围及提示 Data Size & Hint
输入15,17,要在15~30中找到第一个17的倍数,就是它本身,17,所以输出17
#include <bits/stdc++.h>
using namespace std;
int main(){
int n,k;
bool flag=0;
cin>>n>>k;
for(int i=n; i<=n*2; i++){
if(i%17==0){
flag=1;
cout<<i;
}
}
if(flag==0){
cout<<"没找到";
}
return 0;
}
样例都过了为啥是0分?