问题标题: 酷町堂:3793 字符串子串

0
0
已解决
汪宇航
汪宇航
新手启示者
新手启示者

题目描述 Description

给出一个字符串s,求出其所有长度为x的子串并输出。如果不存在长度为x的字符串则输出-1。

输入描述 Input Description

第一行,一个字符串,s
第二行,一个整数,x

输出描述 Output Description

如果存在长度为x的子串,则按在字符串中的先后顺序分别输出所有子串,每行一个
不存在这样的子串则输出-1

样例输入 Sample Input

abcdefg 3

样例输出 Sample Output

abc bcd cde def efg

数据范围及提示 Data Size & Hint

字符串不包含空格

#include <iostream>

using namespace std;

int main(){

string s;

int x,a=0,i;

cin>>s>>x;

if(s.size()<x||x==0){

cout<<"-1";

return 0;

}else{

while(a<=s.size()-3){

cout<<s.substr(a,x);

cout<<"\n";

a++;

}

}

return 0;

}

10分!!!!!!!!!!!!!

@张帆@汪恺恒@赵逸凡

汪宇航在2021-03-14 16:15:42追加了内容

额。。。原本准备搞一个代码的,忘记更改板块了。。。


0
已采纳
张帆
张帆
中级天翼
中级天翼
while(a<=s.size()-3){ //-3?,你确定x=3?

cout<<s.substr(a,x);

cout<<"\n";

a++;

}

 

0
我要回答