0
已解决
王子涵
修练者
修练者
经验值:800
题目描述 Description
给出一个字符串a和n个字符串b1 b2 … bn,将a和b1 b2 … bn分别进行比较。如果a的字典序大于bi,如果i为偶数,则将a的值复制给bi,如果i为奇数,则将a的值连接到bi的后面;如果a的字典序不大于bi,则将bi的值复制给a。
输入描述 Input Description
第一行,一个字符串a和一个整数n,用空格隔开,a n
接下来n行,每行一个字符串,第i+1行为字符串bi
输出描述 Output Description
n行,第i行输出字符串bi
样例输入 Sample Input
bc 4 abcde fghijk almnop abc
样例输出 Sample Output
abcdebc fghijk almnopfghijk fghijk
数据范围及提示 Data Size & Hint
n≤200
每个字符串的长度不超过100,不包含空格
错误代码
#include<cmath>
#include<cstdlib>
#include<iostream>
using namespace std;
int main()
{
string a,b,maxn;
int n;
cin>>a>>n;
cin>>b;
for(int i=1;i<=n;i++)
{
cin>>b;
if(a>b)
{
if(i%2==1)
{
b=b+a;
}
else if(i%2==0)
{
b=a;
}
}
else
{
a=b;
}
cout<<b<<endl;
}
return 0;
}
急急急,在线求解