0
已解决
胡景波
中级光能
中级光能
-
题目描述 Description
现给出一个整数 n(n>=0),求出下式结果,保留两位小数输出:
输入描述 Input Description
输入一个数:n (n>=0)
输出描述 Output Description
输出运行结果:Fn
样例输入 Sample Input
5
样例输出 Sample Output
8.00
数据范围及提示 Data Size & Hint
数据范围:
0<= n <=48 - #include<iostream>
- #include<cmath>
- #include<cstdio>
- using namespace std;
- int n;
- double p(double x,int t){
- double ff=x;
- for(int i=1;i<=t;i++){
- ff=x*ff;
- }
- return ff;
- }
- int main(){
- cin>>n;
- double p1=(1+sqrt(5))*1.0/2,p2=(1-sqrt(5))*1.0/2;
- printf("%.2f",(p(p1,n)-p(p2,n))*1.0/sqrt(5));
- return 0;
- }