问题标题: 酷町堂:1744:

0
1
已解决
许孟星
许孟星
高级守护
高级守护

1744   自助查询机

经验值:400 时间限制:1000毫秒

题目描述 Description

有一些超市为了减少售货员的工作,设置了价格自助查询机,顾客只要点击要查询商品对应的数字,就会显示这个商品对应的价格,目前查询水果的单价。有4种水果,苹果(apples)、梨(pears)、桔子(oranges)和葡萄(grapes),单价分别是3.00元/公斤,2.50元/公斤,4.50元/公斤和9.50元/公斤。
运行程序后,首先在屏幕上显示以下菜单(编号和选项)(见样例)。
当用户输入编号1~4,显示相应水果的单价(保留1位小数);输入0,退出查询;输入其他编号,显示价格为0。

输入描述 Input Description

输入一个整数。

输出描述 Output Description

输出对应的结果。(保留1位小数)

样例输入 Sample Input

3

样例输出 Sample Output

[1] apples [2] pears [3] oranges [4] grapes [0] Exit price=4.5

数据范围及提示 Data Size & Hint

在编译运行以后就会输出
[1] apples
[2] pears
[3] oranges
[4] grapes
[0] Exit

#include<iostream>
using namespace std;
int main(){
    cout<<"[1] apples"<<endl;
    cout<<"[2] pears"<<endl;
    cout<<"[3] oranges"<<endl;
    cout<<"[4] grapes"<<endl;
    cout<<"[0] Exit"<<endl;
    int a;
    cin>>a;
    if(a==1){
        cout<<"price=3.0";
    }
    if(a==2){
        cout<<"price=2.5";
    }
    if(a==3){
        cout<<"price=4.5";
    }
    if(a==4){
        cout<<"price=9.5";
    }
    if(a==0){
        cout<<"price=Exit";
    }
    if(a!=1 && a!=2 && a!=3 && a!=4 && a!=0){
        cout<<"price=0";
    }
    return 0;
}

哪错了?


0
0
武奕楷
武奕楷
新手天翼
新手天翼

int a;

double b;

cout<<"[1] apples"<<endl<<"[2] pears"<<endl;

cout<<"[3] oranges"<<endl<<"[4] grapes"<<endl;

cout<<"[0] Exit"<<endl;

cin>>a;

if(a==1||a==2||a==3||a==4||a==0){

if(a==1){

cout<<"price=3.0";

}

else{

if(a==2){

cout<<"price=2.5";

}

else{

if(a==3){

cout<<"price=4.5";

}

else{

if(a==4){

cout<<"price=9.5";

}

}

}

}

}

else{

cout<<"price=0";

}

我要回答