问题标题: 酷町堂:3725

0
0
已解决
李熙尧
李熙尧
新手光能
新手光能

3725   出现次数

经验值:0 时间限制:1000毫秒

题目描述 Description

输入一个正整数n(最大不超过long long),再输入一个整数m(m小于等于n的位数),求整数n中的从右到左的第m个数字,在整数n中的个数。

输入描述 Input Description

输入两个空格隔开的整数n 、m

输出描述 Output Description

输出第m个数在n中出现的次数。

样例输入 Sample Input

1223334444 5

样例输出 Sample Output

3

数据范围及提示 Data Size & Hint

从右往左第5个数是3,3在1223334444中出现了3次。

错误代码

#include<iostream>
#include<cmath>
using namespace std;
long long a,cnt,b,m,n,cnt1;
int main(){
    cin>>a>>b;
    m=a;
    n=m;
    while(a>0){
        cnt++;
        a/=10;
    }
    for(int i=1;i<=b;i++){
        m/=10;
    }
    for(int i=1;i<=cnt;i++){
        if((int)(n/pow(10,i))%10==(m%10)){
            cnt1++;
        }
    }
    cout<<cnt1;
    return 0;
}

 


0
0
0
0
0
我要回答