问题标题: 酷町堂:1744 12fen

0
0
已解决
颜咏春
颜咏春
中级光能
中级光能

1744   自助查询机

题目描述 Description

有一些超市为了减少售货员的工作,设置了价格自助查询机,顾客只要点击要查询商品对应的数字,就会显示这个商品对应的价格,目前查询水果的单价。有4种水果,苹果(apples)、梨(pears)、桔子(oranges)和葡萄(grapes),单价分别是3.00元/公斤,2.50元/公斤,4.50元/公斤和9.50元/公斤。 运行程序后,首先在屏幕上显示以下菜单(编号和选项)(见样例)。 当用户输入编号1~4,显示相应水果的单价(保留1位小数);输入0,退出查询;输入其他编号,显示价格为0。

输入描述 Input Description

输入一个整数。

输出描述 Output Description

输出对应的结果。

样例输入 Sample Input

 

3

样例输出 Sample Output

 

[1] apples
[2] pears
[3] oranges
[4] grapes
[0] Exit
price=4.5

数据范围及提示 Data Size & Hint

在编译运行以后就会输出
[1] apples
[2] pears
[3] oranges
[4] grapes
[0] Exit

 

1744   自助查询机

Wrong Answer:12分

测试点#1测评结果 : Wrong Answer时间 : 0ms偷看一下数据

测试点#2测评结果 : Wrong Answer时间 : 0ms偷看一下数据

测试点#3测评结果 : Wrong Answer时间 : 0ms偷看一下数据

测试点#4测评结果 : Accepted时间 : 0ms

测试点#5测评结果 : Wrong Answer时间 : 0ms偷看一下数据

测试点#6测评结果 : Wrong Answer时间 : 0ms偷看一下数据

测试点#7测评结果 : Wrong Answer时间 : 0ms偷看一下数据

测试点#8测评结果 : Wrong Answer时间 : 0ms偷看一下数据

 

#include<iostream>
using namespace std;
int main()
{
    int n,x,b;
    cin>>n;
    if(n==1)  
    {
        cout<<"[1] apples"<<endl;
        cout<<"[2] pears"<<endl;
        cout<<"[3] oranges"<<endl;
        cout<<"[4] grapes"<<endl;
        cout<<"[0] Exit";
        cout<<endl;
        cout<<"price=";
        cout<<"3.0";
    }
    if(n==2)
    {
        cout<<"[1] apples"<<endl;
        cout<<"[2] pears"<<endl;
        cout<<"[3] oranges"<<endl;
        cout<<"[4] grapes"<<endl;
        cout<<"[0] Exit";
        cout<<endl;
        cout<<"price=";
        cout<<"2.5";
    }
    if(n==3)
    {
        cout<<"[1] apples";
        cout<<endl;
        cout<<"[2] pears";
        cout<<endl;
        cout<<"[3] oranges"<<endl;
        cout<<"[4] grapes"<<endl;
        cout<<"[0] Exit";
        cout<<endl;
        cout<<"price=";
        cout<<"4.5";
    }
    if(n==4)
    {
        cout<<"[1] apples";
        cout<<endl;
        cout<<"[2] pears";
        cout<<endl;
        cout<<"[3] oranges"<<endl;
        cout<<"[4] grapes"<<endl;
        cout<<"[0] Exit";
        cout<<endl;
        cout<<"price=";
        cout<<"9.5";
    }
    else
    {
        cout<<"0";
    }
    return 0;
}

1
已采纳
陆麟瑞
陆麟瑞
资深天翼
资深天翼

这道题你要还没读入时就输出

[1] apples
[2] pears
[3] oranges
[4] grapes
[0] Exit

就像这样

cout<<"[1] apples"<<endl;
    cout<<"[2] pears"<<endl;
    cout<<"[3] oranges"<<endl;
    cout<<"[4] grapes"<<endl;
    cout<<"[0] Exit"<<endl;
    cin>>n;
然后在用if依次判断
if(n!=0)cout<<"price=";//如果n不是0,就输出price
    if(n==1) cout<<"3.0";
    else if(n==2) cout<<"2.5";
    else if(n==3) cout<<"4.5";
    else if(n==4) cout<<"9.5";
    else if(n!=0) cout<<0;//如果其他有不为0的数,就输出0
1
马佳滢
马佳滢
新手天翼
新手天翼

改法:

 if(n==2)
 变成
 else if(n==2)


 if(n==3)
 变成
 else if(n==3) 


 if(n==4)
 变成
 else if(n==4)

然后在
else 
前面加判断
else if(n==0)
    {
        cout<<"[1] apples";
        cout<<endl;
        cout<<"[2] pears";
        cout<<endl;
        cout<<"[3] oranges"<<endl;
        cout<<"[4] grapes"<<endl;
        cout<<"[0] Exit";
        cout<<endl;
        cout<<" ";
    }

 

1
栾峻岩
栾峻岩
初级天翼
初级天翼

先按要求输出,他是先输出,再输入,你是先输入、再输出。

 else
    {
        cout<<"0";
    }

这里错了,应是:

 if (a>4 && (a!=1 && a>1))
        cout<<"price=0";

 

0
张马润泽
张马润泽
初级光能
初级光能

点错误测试点是Not found

0
0
我要回答