0
已解决
丁博扬
中级天翼
中级天翼
5136 读书日
经验值:0 时间限制:1000毫秒
题目描述 Description
小彬从书店买回来一本好看的书,他非常喜欢这本书,想要尽快读完,这本书总共有n页,小彬每分钟可以读s页,但是小彬的****提示,每连续读t分钟之后要放松一下,休息r分钟,放松一下眼睛。问:小彬多久之后可以把整本书读完。
输入描述 Input Description
输入四个数字,n,s,t,r
输出描述 Output Description
输出小彬读完整本书的时间
样例输入 Sample Input
10 6 1 5
样例输出 Sample Output
7
#include<iostream>
using namespace std;
int cnt,sum;
int main(){
int a,b,c,d;
cin>>a>>b>>c>>d;
while(1){
if(sum+c*d<a){
sum+=c*d;
cnt+=c;
cnt+=d;
}
else{
cnt+=(int)((a*1.0-sum)/b+0.99999);
break;
}
}
cout<<cnt;
return 0;
}
以前AC过的,这是打卡题,结果就是忘记怎么写了
呜呜呜