0
已解决
李泽屿
新手启示者
新手启示者
题目链接: 酷町堂:2216
2216 数组循环平移
经验值:0 时间限制:1000毫秒 内存限制:128MB
题目描述 Description
将a数组中第一个元素移到最后数组末尾,其余数据依次往前平移一个位置。输出移动过后数组元素,数组元素为不大于1000的正整数。
输入描述 Input Description
两行
第一行,数组元素个数n(4<n<20)
第二行,n个数组元素,数字之间用空格隔开
输出描述 Output Description
经过变化以后数组元素
样例输入 Sample Input
5 1 2 3 4 5
样例输出 Sample Output
2 3 4 5 1
#include<iostream>
#include<cstdio>
using namespace std;
int a[25];
int main(){
int n,sum=0;
cin>>n;
for(int i=1;i<n;i++){
cin>>a[i];
if(a[i]=a[0]){
sum=a[i];
}else{
cout<<a[i]<<" ";
}
}
cout<<sum;
return 0;
}