问题标题: 酷町堂:1744 自助查询机

0
0
已解决
於海洋
於海洋
高级光能
高级光能

题目链接: 酷町堂:1744

单击显示题目

题目:

1744   自助查询机

经验值:400 时间限制:1000毫秒 内存限制:128MB

题目描述 Description

有一些超市为了减少售货员的工作,设置了价格自助查询机,顾客只要点击要查询商品对应的数字,就会显示这个商品对应的价格,目前查询水果的单价。有4种水果,苹果(apples)、梨(pears)、桔子(oranges)和葡萄(grapes),单价分别是3.00元/公斤,2.50元/公斤,4.50元/公斤和9.50元/公斤。
运行程序后,首先在屏幕上显示以下菜单(编号和选项)(见样例)。
当用户输入编号1~4,显示相应水果的单价(保留1位小数);输入0,退出查询;输入其他编号,显示价格为0。

输入描述 Input Description

输入一个整数。

输出描述 Output Description

输出对应的结果。(保留1位小数)

样例输入 Sample Input

3

样例输出 Sample Output

[1] apples [2] pears [3] oranges [4] grapes [0] Exit price=4.5

数据范围及提示 Data Size & Hint

在编译运行以后就会输出
[1] apples
[2] pears
[3] oranges
[4] grapes
[0] Exit

 

 

 

代码:

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
    int a;
    cout<<"[1] apples"<<"\n"<<"[2] pears"<<endl<<"[3] oranges"<<"\n"<<"[4] grapes"<<endl<<"[0] Exit";
    cin>>a;
    if(a==1){
        cout<<"price=";
        cout<<setprecision(1)<<fixed<<3.00; 
    }else if(a==2){
        cout<<"price=";
        cout<<setprecision(1)<<fixed<<2.50;
    }else if(a==3){
        cout<<"price=";
        cout<<setprecision(1)<<fixed<<4.50;
    }else if(a==4){
        cout<<"price=";
        cout<<setprecision(1)<<fixed<<9.50;
    }else if(a==0){
        return 0;
    }else{
        cout<<0;
    }
    return 0;
}

为什么12分?


0
我要回答