中级光能
题目链接: 酷町堂:3970
题目描述 Description
形如 a^3= b^3 + c^3 + d^3 的等式被称为完美立方等式。例如 12^3= 6^3 + 8^3 + 10^3 。编写一个程序,对任给的正整数N,寻找所有的四元组(a,b,c,d),使得a^3 = b^3 + c^3 + d^3,其中a,b,c,d 大于 1, 小于等于N,且b<=c<=d。
输入描述 Input Description
一个正整数N (N≤100)。
输出描述 Output Description
请输出满足条件的a,b,c,d的值,请按照a的值,从小到大依次输出,当两个完美立方等式中a的值相同,则b值小的优先输出、仍相同则c值小的优先输出、再相同则d值小的先输出。
样例输入 Sample Input
24
样例输出 Sample Output
6 3 4 5
12 6 8 10
18 2 12 16
18 9 12 15
19 3 10 18
20 7 14 17
24 12 16 20
#include<iostream>
#include<algorithm>
using namespace std;
int s[5];
int main(){
int n;
cin>>n;
for(int a=2;a<=n;a++){
for(int b=2;b<=n;b++){
for(int c=2;c<=n;c++){
for(int d=2;d<=n;d++){
if(a*a*a==b*b*b+c*c*c+d*d*d){
cout<<a<<" ";
s[1]=b;
s[2]=c;
s[3]=d;
sort(s+1,s+4);
for(int r=1;r<=3;r++){
cout<<s[r]<<" ";
}
cout<<"\n";
}
}
}
}
}
return 0;
}
输入:
24
输出:
6 3 4 5
6 3 4 5
6 3 4 5
6 3 4 5
6 3 4 5
6 3 4 5
12 6 8 10
12 6 8 10
12 6 8 10
12 6 8 10
12 6 8 10
12 6 8 10
18 2 12 16
18 2 12 16
18 9 12 15
18 9 12 15
18 2 12 16
18 9 12 15
18 9 12 15
18 2 12 16
18 9 12 15
18 9 12 15
18 2 12 16
18 2 12 16
19 3 10 18
19 3 10 18
19 3 10 18
19 3 10 18
19 3 10 18
19 3 10 18
20 7 14 17
20 7 14 17
20 7 14 17
20 7 14 17
20 7 14 17
20 7 14 17
24 12 16 20
24 12 16 20
24 12 16 20
24 12 16 20
24 12 16 20
24 12 16 20