问题标题: 酷町堂:1801 换小额钞票

0
0
已解决
贾一凡
贾一凡
中级光能
中级光能

题目链接: 酷町堂:1801

题目描述 Description

小明**是开超市的,每天都要卖很多东西,需要准备很多零钱,某一天超市零钱不够了,于是她去银行换钞票,想把n张100元的钞票兑换成10元、20元、50元小钞票形式。请问有多少种兑换的方式呢?

输入描述 Input Description

100元的钞票的数量n张(1<=n<=10000)

输出描述 Output Description

多少种换法

样例输入 Sample Input

1

样例输出 Sample Output

10

 

#include<iostream>
using namespace std;
int main(){
    int n,cnt=0;
    cin>>n;
    for(int i=0;i<=n*100/10;i++){ //10元钞票张数 
        for(int j=0;j<=n*100/20;j++){ //20元钞票张数 
            for(int k=0;k<=n*100/50;k++){ //50元钞票张数 
                if(i*10+j*20+k*50==n*100){
                    cnt++;
                }
            }
        }
    }
    cout<<cnt;
    return 0;
}

 

 

Time Limit Exceeded:20分

大佬们找错!


0
我要回答