1
已解决
穆星瞳
初级守护
初级守护
题目描述 Description
给定一个m行n列的二维数组,请原样输出这个二维数组(m和n范围为2-20)
输入描述 Input Description
m+1行:
第一行,矩阵的行m和列n,两个数字用空格隔开
接下来的m行,矩阵里各个元素(元素数字范围0-100)
输出描述 Output Description
m行:原样输出的矩阵元素
样例输入 Sample Input
2 3
1 2 3
4 5 6
样例输出 Sample Output
1 2 3
4 5 6
#include<iostream>
using namespace std;
int a[101][101];
int main()
{
int m,n;
cin>>m>>n;
for(int i=0;i<m;++i)
for(int j=0;j<n;++j)
{
cin>>a[i][j];
}
for(int i=0;i<m;++i)
for(int j=0;j<n;++j)
{
cout<<a[i][j]<<" ";
if(i==n)
{
cout<<endl;
}
}
}
请大师帮忙看看哪里错了!
0
0
0
0
黄昊轩
新手守护
新手守护
for(int i=0;i<n;i++) { for(int j=0;j<m;j++) cin>>a[i][j]; } for(int i=0;i<n;i++) { for(int j=0;j<m;j++) { cout<<a[i][j]<<' '; } cout<<endl; }
0
0
孙坚恒
资深守护
资深守护
int n,m; cin>>n>>m;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
cin>>a[i][j];
}
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
cout<<a[i][j]<<" ";
cout<<endl;
0
0