问题标题: 酷町堂:7671 数字三角形

0
0
已解决
张逸凡
张逸凡
高级守护
高级守护

题目链接: 酷町堂:7671

酷酷最近学习了C++,想要在屏幕中显示出一个由数字组成的等腰直角三角形,从数字1开始,第一行有1个数字,第二行有2个数字,…,第n行有n个数字,请你帮助酷酷解决这个问题。

输入描述 Input De**ion

输入一行,是一个整数n

输出描述 Output De**ion

输出n行,第m行有m个数字,每个数字占据四个位置。
注:c语言中 %4d可以输出一个数,占据四个位置,右对齐。

样例输入 Sample Input

3

样例输出 Sample Output

1 2 3 4 5 6

数据范围及提示 Data Size & Hint

1<=n<=1000

#include<bits/stdc++.h>

using namespace std;

int main(){

int a;

cin>>a;

for(int i=1;i<=a;i++){

for(int j=1;j<=i;j++){

cout<<i<<" ";

}cout<<endl;

}

return 0;

}


0
0
0
0
0
0
我要回答