问题标题: 酷町堂:7393 函数求次方

0
0
已解决
张铭睿
张铭睿
中级光能
中级光能

题目链接: 酷町堂:7393

7393   函数求次方

经验值:100 时间限制:1000毫秒 内存限制:128MB

题目描述 De**ion

给出整数a和b,请使用函数求a的b次方的值

输入描述 Input De**ion

输入为两个整数a和b,中间用空格分隔

输出描述 Output De**ion

输出为一个整数,即为a的b次方的结果

样例输入 Sample Input

2 3

样例输出 Sample Output

8

数据范围及提示 Data Size & Hint

a<=20, b<=10

 

 

 

 

 

0分代码

#include<iostream>

#include<cmath>

#include<iomanip>

using namespace std;

int a,b;

int main(){

    cin>>a>>b;

cout<<pow(a,b);

    return 0;

}


0
已采纳
侯世宸
侯世宸
高级守护
高级守护

pow函数超过一定范围就会使用科学计数法,所以你该定义一个n,把n变成pow(a,b),最后输出n。(注意n要用long long)

0
孔德怡
孔德怡
新手光能
新手光能

在第一行代码后面输<cmath>(#incl......我不说了,ioman......不要)

int a,b;

long long n;

输入>>a>>b;

n=pow(a,b);

输出<<n;

望采纳,谢谢

0
我要回答