0
已解决
张逸凡
高级守护
高级守护
题目链接: 酷町堂:2253
2253 趣味运动会得分
经验值:1200
时间限制:1000毫秒
内存限制:128MB
题目描述 De**ion
酷町堂举办了一场趣味运动会,运动会一共有 n 轮,现在有每轮比赛的得分情况,老师想知道他的得分一直上升的最长连续轮数。
输入描述 Input De**ion
第一行:一个整数N
第二行:N个空格隔开的整数,表示贾老师 N 轮比赛的得分。
输出描述 Output De**ion
一个整数,表示得分一直上升的最长连续轮数。
样例输入 Sample Input
10 1 2 3 2 4 5 6 8 5 9
样例输出 Sample Output
5
数据范围及提示 Data Size & Hint
1<=N<=10^5
0<=每轮的得分<=10^7
me:
#include<bits/stdc++.h>
using namespace std;
int a[999999],sum,pos;
int main(){
int n;
cin>>n;
for(int i=1;i<=n;i++){
cin>>a[i];
}
for(int i=1;i<=n;i++){
for(int j=i+1;j<=n;j++){
//cout<<pos<<" ";
if((a[j]-a[i])>sum){
sum=a[j];
pos=j;
}
}
}
cout<<pos;
return 0;
}
求代码