0
已解决
贾智衡
高级守护
高级守护
7423 新闻循环播报
经验值:800
时间限制:1000毫秒
内存限制:128MB
题目描述 De**ion
央视新闻每7小时播报一次,假设第一次播报是在早上7:00,那么第x次播报是在几点?时间是24小时制,从0:00到23:59。
输入描述 Input De**ion
一个整数x
输出描述 Output De**ion
输出时间,格式必须是xx:xx,也就是时和分各占2位
样例输入 Sample Input
2
样例输出 Sample Output
14:00
数据范围及提示 Data Size & Hint
x<=100
代码:
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
int main() {
int x;
cin>>x;
if((7+(x-1)*7)%24==0)printf("%d:00",24);
else printf("%d:00",(7+(x-1)*7)%24);
return 0;
}