0
已解决
叶珂睿
新手天翼
新手天翼
题目链接: 酷町堂:2216
2216 数组循环平移
经验值:800
时间限制:1000毫秒
内存限制:128MB
题目描述 De**ion
将a数组中第一个元素移到最后数组末尾,其余数据依次往前平移一个位置。输出移动过后数组元素,数组元素为不大于1000的正整数。
输入描述 Input De**ion
两行
第一行,数组元素个数n(4<n<20)
第二行,n个数组元素,数字之间用空格隔开
输出描述 Output De**ion
经过变化以后数组元素
样例输入 Sample Input
5 1 2 3 4 5
样例输出 Sample Output
2 3 4 5 1
#include<iostream>
#include<iomanip>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
int a[1100];
int main(){
int n,j;
cin>>n;
for(int i=1;i<=n;i++){
cin>>a[i];
}
j=a[0];
for(int i=1;i<=n;i++){
a[i]=a[i+1];
a[n-1]=j;
}
for(int i=1;i<=n;i++){
cout<<a[i]<<" ";
}
return 0;
}