0
已解决
李安雅
中级守护
中级守护
1066 去重
经验值:1200
时间限制:1000毫秒
内存限制:128MB
题目描述 De**ion
一整型序列,可能存在相同的元素,请去掉重复的元素且只保留一个,输出经过去重的序列。若没有重复的元素,则输出原序列。
输入描述 Input De**ion
输入为两行:
第一行包含一个整数N,为序列的长度(N≤100);
第二行为N个整数(0~10000)。
输出描述 Output De**ion
若有重复的元素,输出去重后的序列,否则,输出原序列。
样例输入 Sample Input
10 1 2 3 1 2 3 4 5 6 10
样例输出 Sample Output
1 2 3 4 5 6 10
50分代码,麻烦帮我看一看
#include<iostream>
#include<iomanip>
#include<string>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
int n,a[105],b[10005];
int main(){
cin>>n;
for(int i=1;i<=n;i++){
cin>>a[i];
b[a[i]]++;
}
for(int i=0;i<=10000;i++){
if(b[i]>0){
cout<<i<<" ";
}
}
return 0;
}
李安雅在2023-09-10 11:49:46追加了内容