0
已解决
张司桥
中级光能
中级光能
题目链接: 酷町堂:4894
题目描述 De**ion
酷町猫来到了二维空间,要想在这里生存,首先得掌握二维空间的基本准则,即要会使用二维空间的输入输出
输入描述 Input De**ion
输入共n+1行
第一行 两个数n,m;
接下来n行,每行m个数
输出描述 Output De**ion
输出n行,每行倒着输出每一行的元素
样例输入 Sample Input
2 3 1 2 3 2 3 4
样例输出 Sample Output
3 2 1 4 3 2
数据范围及提示 Data Size & Hint
n,m<=100
请问错哪?
#include<bits/stdc++.h>
using namespace std;
int n,m;
int a[105][105];
int main(){
cin>>n>>m;
for(int i=1;i<=n;i++){
for(int j=1;j<=m;j++){
cin>>a[i][j];
}
}
for(int i=n;i>=1;i--){
for(int j=m;j>=1;j--){
cout<<a[i][j]<<" ";
}
cout<<endl;
}
return 0;
}