0
已解决
李安雅
中级守护
中级守护
10790 你问我答1
经验值:400
时间限制:1000毫秒
内存限制:128MB
题目描述 Deion
酷酷和酷町猫在玩一个“你问我答”的小游戏,游戏规则是这样的:游戏共进行t轮问答,每轮问答开始时,酷酷给出两个数字x、y,酷町猫需要回答出x到y之间所有数字的和。
输入描述 Input Deion
第一行:1个整数n
接下来n行,每行两个数字x、y
输出描述 Output Deion
n行,每行一个数字,表示x到y之间所有数字的和
样例输入 Sample Input
5 1 3 2 5 1 10 1 100 2 2
样例输出 Sample Output
6 14 55 5050 2
数据范围及提示 Data Size & Hint
n ≤≤ 20
1 ≤≤ x ≤≤ y ≤≤ 1000
错误代码:
#include<iostream>
#include<iomanip>
#include<string>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<cstdlib>
using namespace std;
int n,x,y;
int sum=0;
int main(){
cin>>n;
for(int i=1;i<=n;i++){
cin>>x>>y;
for(int j=x;j<=y;j++){
sum+=j;
}
cout<<sum<<endl;
}
return 0;
}
哪儿错了?