问题标题: 酷町堂:2711

0
0
已解决
薛新奥
薛新奥
新手光能
新手光能
2711   多少个空格
题目描述 Description
输入一行字符串,请你找到这个字符串中有多少个空格。
输入描述 Input Description
一行:输入字符串
输出描述 Output Description
一个数字:字符串中的空格数
样例输入 Sample Input
Hello miao miao
样例输出 Sample Output
2
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a[2000];
    gets(a);
    int x;
    x=strlen(" ");
    cout<<x;
    return 0;
} 

 


0
0
李祈乐
李祈乐
新手光能
新手光能

输入这个字符串,需要循环判断这个字符串,如果其中某个字符是空格x++;

即:

 int x=0;
    for(int i=0;i<strlen(a);i++)
    {
        if(a[i]==' ')
            x++;
    }

 

0
我要回答