问题标题: 1001

0
0
已解决
谈文瑞
谈文瑞
新手光能
新手光能
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,a,o,j;
     for(int i=0;i<n;i++)
    {
        cin>>a;
        if(a%2==0)
            o++;
        else
            j++;
    }
    cout<<j<<endl;
    cout<<o<<endl;
    return 0;
 } 

哪错了?谢谢!

1001   统计奇偶数的个数

题目描述 Description

对于输入的n个正整数,统计其中奇数、偶数的个数。

输入描述 Input Description

输入两行,第一行为n,第二行输入n个正整数。

输出描述 Output Description

输出两行,奇数个数在第一行,偶数个数在第二行。如下所示,冒号“:”为英文符号。
jishu:5 
oushu:5

样例输入 Sample Input

 

10
1 2 3 4 5 6 7 8 9 10

样例输出 Sample Output

 

jishu:5
oushu:5


0
已采纳
张瑀涵
张瑀涵
高级光能
高级光能

你的n没有输入

0
欧阳语聪
欧阳语聪
资深守护
资深守护
for(int i=1;i<=a;i++){
            cin>>d;
        if(d%2==0){
            b+=1;
        }
        if(d%2==1){
            c+=1;
        }
    } 
0
张瑀涵
张瑀涵
高级光能
高级光能

你的j,o应该先赋值为0。

0
0
张瑀涵
张瑀涵
高级光能
高级光能

cout<<j<<endl;

 

cout<<o<<endl;

改成

cout<<"jishu:"<<j<<endl;

cout<<"oushu:"<<o<<endl;

 

0
0
0
0
0
0
臧启亚
臧启亚
初级光能
初级光能
    for (int i=0;i<n;i++){
        cin>>a[i];
        if (a[i]%2!=0)s++;else x++;
    }
0
梁锦程
梁锦程
高级光能
高级光能
for(i = 0; i < n; i ++){
        cin >> x;
        if(x%2 == 0) t1 ++;
        else t2 ++; 
    }
我要回答