问题标题: 1604

0
0
已解决
谈文瑞
谈文瑞
新手光能
新手光能
#include<bits/stdc++.h>
using namespace std;
int main()
{
    double s=0.1;
    cin>>n;
    while(s<n)
    {
        i++;
        s*=2;
    }
    cout<<i;
    return 0;
 } 

哪错了?谢谢!

1604   折纸

题目描述 Description

有一张纸,其厚度为0.1毫米,将它对折多少次会超过桌面板的厚度n,(10<n<30)

输入描述 Input Description

桌面的厚度n

输出描述 Output Description

对折的次数

样例输入 Sample Input

 

5

样例输出 Sample Output

 

6


1
已采纳
张瑀涵
张瑀涵
高级光能
高级光能

你没有设置i,而且i设置时要赋值为0.

0
欧阳语聪
欧阳语聪
资深守护
资深守护
while(a>=i){
        i*=2;
        b+=1;   
        }
        cout<<b;
0
时梓繁
时梓繁
修练者
修练者
  double s=0.1,n,i;
    cin>>n;
    while(s<n)
    {
        i++;
        s*=2;
    }
    cout<<i;
我要回答