问题标题: 酷町堂:2705 选择供应商

1
0
已解决
张舒斌
张舒斌
中级光能
中级光能

2705   选择供应商

题目描述 Description

某学校要进行重新装潢,一共需要三种不同的材料,现在有多个供应商可以提供所有装潢需要的材料,供应商提供三种材料的价格,价格为0表示该种供应商没有那一种材料,学校想处理的越简单越好,所以打算选择一个可以提供三种材料的某一家供应商来买,且三种材料的平均价格越低越好。

输入描述 Input Description

第一行:n,表示有n个供应商,n<60
接下来n行:每行先有一个字符串表示供应商的名字,然后有三个数字分别表示三种不同材料的价格,价格为0表示此家供应商没有那一种材料

输出描述 Output Description

输出一行,为选中的供应商的信息,包括供应商的名字和此家三种材料的价格

样例输入 Sample Input

 

10
IuUjgKA 9 0 10
v 6 0 2
JBhLeCdA 8 9 1
ZPymTsna 7 8 1
DaCpcjBR 8 1 0
K 6 6 1
lh 8 3 4
YNgoOdBU 8 10 4
Lh 10 5 7
WbKuli 3 6 1

样例输出 Sample Output

 

WbKuli 3 6 1

#include<bits/stdc++.h>
using namespace std;
struct xxzh
{
    string name;
    int cl1,cl2,cl3;
}a[100];
int main()
{
    int n,count=1;
    cin>>n;
    int sum[n]={9999999};
    for(int i=1;i<=n;i++)
    {
        cin>>a[i].name>>a[i].cl1>>a[i].cl2>>a[i].cl3;
        if(a[i].cl1!=0&&a[i].cl2!=0&&a[i].cl3!=0)
            sum[count++]=a[i].cl1+a[i].cl2+a[i].cl3;
    }
    //输入和求和都写完了,排序咋写?
    return 0;
}

 


0
0
我要回答