问题标题: 酷町堂:1807 时,分,秒

0
0
已解决
黄品翔
黄品翔
初级光能
初级光能

题目描述 Description

给定一个秒数,让其转化为小时"分钟"的形式,忽略剩下的秒数。

输入描述 Input Description

秒数

输出描述 Output Description

转化的时间

样例输入 Sample Input

 

120

样例输出 Sample Output

 

0"2"

数据范围及提示 Data Size & Hint

秒数范围为(1-10000)

 

80分错误代码:

#include<bits/stdc++.h>
using  namespace  std;
int  main()
{
    int  a,b=0,c=0;
    cin>>a;
    if(a<60)
    {
        b=0;
        c=0;
    }
    if(a>=60&&a<3600)
    {
        b=0;
        c=a/60;
    }
    if(a>=3600)
    {
        b=a/3600;
        c=(a-b)/60;
    }
    cout<<b<<'"'<<c<<'"';
    return  0;
}

请巨佬们先说错误原因再来代码,谢谢!!!


0
已采纳
桑烁
桑烁
高级光能
高级光能

最后一个判断c的值错了

应该为b=a/60,c=b-b/60*60(输出时再将b/60)

1
傅文彬
傅文彬
新手天翼
新手天翼

#include<bits/stdc++.h>

using namespace std;

int main()

{

long long n;

输入>>n;

cout<<n/3600<<"\""<<n/60%60<<"\"";

return 0;

}

0
0
舒航
舒航
新手守护
新手守护

你的太麻烦

 int n,k=0,y=0;
    cin>>n;
    k=n/60;
    if(k>=60)
    {
        y=k/60;
        k=k%60;
    }
    cout<<y<<'"'<<k<<'"';
0
高梓荣
高梓荣
新手天翼
新手天翼

@黄品翔 你好:

自我感觉这题太水了,给你AC超简易代码:

#include<iostream>
using namespace std;
int main()
{
    long long n;
    输入>>n;
    cout<<n/3600<<"\""<<n/60%60<<"\"";
    return 0; 
}

 

0
李正轩
李正轩
中级守护
中级守护

 

#include<stdio.h>
int main()
{
    int h,m,s,seconds;
    printf("input sec: ");scanf("%d", &seconds );
    h=seconds/3600;
    seconds %= 3600 ;
    m=seconds/60;
    s=seconds%60;
    printf("%d:%d:%d\n", h,m,s );
    return 0;
}

我把秒也带上

我要回答