问题标题: 酷町堂:3853

0
0
已解决
尹宗鑫
尹宗鑫
新手守护
新手守护

3853   小数排序

题目描述 Description

现在有n(不超过50000)个小数(小数点后有2位),范围在1.00~9.99,从小到大排序输出

输入描述 Input Description

第一行输入一个整数n(不超过50000)
接下来n行,每行输入一个小数(1.00~9.99)

输出描述 Output Description

按照样例格式,输出排序后的数据,保留2位小数

样例输入 Sample Input

 

5
1.10
2.51
3.21
4.45
2.12

样例输出 Sample Output

 

1.10 2.12 2.51 3.21 4.45

 

http://judge.codingtang.com/problem/3853/

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int n;
double a[101];
int main(){
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>a[i];
        sort(a+1,a+n+1);
    for(int i=1;i<=n;i++)
        printf("%.2f ",a[i]);
    return 0;
}

50分代码

为什么错了


0
已采纳
桑烁
桑烁
高级光能
高级光能

数组范围小了

题目说是<=50000

而定义是101

改下范围应该就AC了

 

0
0
金一铭
金一铭
新手光能
新手光能

您好,您设的数据太小了,比题目规定的范围小多了,所以改大一点,最好大于范围,否则会导致运行错误。

0
0
我要回答