0
已解决
黄品翔
初级光能
初级光能
1164 比较字符串大小
题目描述 Description
输入两个数字字符串,将其转换为数值后,再比较它们的大小。
输入描述 Input Description
输入两行,第一行为数字字符串A,第二行为数字字符串B。(字符串长度小于10)
输出描述 Output Description
输出较大的数值。
样例输入 Sample Input
1234
234
样例输出 Sample Output
1234
50分错误代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
string a,b;
cin>>a>>b;
int x=a.size(),y=b.size();
if(x>y)
{
cout<<a;
}
else if(x<y)
{
cout<<b;
}
return 0;
}
好像有个函数叫 atoi ,可以把字符串转换为数值,但我不会用啊!!!
啊!!!啊!!!啊!!!
0
已采纳
徐睿涵
初级守护
初级守护
else if(s1<s2)cout<<b; else if(s1==s2){if(strcmp(a,b)>0)cout<<a;else if(strcmp(a,b)<0)cout<<b;else cout<<a;}
核心代码
0
0
0
0
0
0