问题标题: 酷町堂:1164

0
0
已解决
徐紫尘
徐紫尘
高级光能
高级光能

题目描述 Description

输入两个数字字符串,将其转换为数值后,再比较它们的大小。

输入描述 Input Description

输入两行,第一行为数字字符串A,第二行为数字字符串B。(字符串长度小于10)

输出描述 Output Description

输出较大的数值。

样例输入 Sample Input

 

1234
234

样例输出 Sample Output

 

1234

#include<iostream>
#include<string>
using namespace std;
int main()
{
    string a,b;
    cin>>a>>b;
    if(b<a)cout<<b;
    else cout<<a;
    return 0;
}

哪错了!


0
已采纳
董子墨
董子墨
中级天翼
中级天翼

先比较长度,再比较大小

0
0
0
0
欧阳语聪
欧阳语聪
资深守护
资深守护
int a,b;
    cin>>a>>b;
    if(a>b)
    cout<<a;
    if(a<b)
    cout<<b;
我要回答