问题标题: 酷町堂:2076???

0
0
已解决
刘承志
刘承志
中级光能
中级光能

题目描述 Description

现在食品安全管理局要对合肥市某条街道上的n家卖食物的店铺进行食品安全的检查,检查共分为五大项,每项总分十分,每家店铺的总分为50分,得分高于或者等于45分的店铺可以被评为“优秀”等级,现给出这n家店铺的得分,请你输出可以获得“优秀”等级的店铺的名称和n家店铺中能获得该等级的店铺的数量。

输入描述 Input Description

第一行:n,n<80
接下来n行:每行先输入店铺的名称,再输入五个整数,分别表示该店铺的五项检查的得分

输出描述 Output Description

第一行:能获得“优秀”等级的店铺的名称,之间用一个空格隔开
第二行:n家店铺获得“优秀”等级的店铺的数量

样例输入 Sample Input

 

3
DIDI 9 9 9 9 10
KUKU 8 7 9 7 8
HALU 5 6 8 8 7

样例输出 Sample Output

 

DIDI
1

 

 

 

 

#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
struct quir{
    string ne;
    int q,w,e,r,t;
}a[81];
int main()
{
    int n,ny=0;
    cin>>n;
    getchar();
    for(int i=1;i<=n;i++){
        cin>>a[i].ne>>a[i].q>>a[i].w>>a[i].e>>a[i].r>>a[i].t;
        int v=a[i].q+a[i].w+a[i].e+a[i].r+a[i].t;
        if(v>=45)
            cout<<a[i].ne<<" ";
        ny++;
    }
    cout<<endl<<ny;
    return 0;
}

为什么不对??????????????????

 

 

 


0
0
被禁言 何冯成
何冯成
中级光能
中级光能

核心:

struct jp
{
    string name;
    int a,b,c,d,e;
};
jp cj[81];

 

 if(t>=45)
        {
            if(num>=1)
            cout<<" ";
            cout<<cj[i].name;
            num++;
        } 

0
0
0
0
0
徐紫尘
徐紫尘
高级光能
高级光能

struct jp
{
    string name;
    int a,b,c,d,e;
};
jp cj[81];

 

 if(t>=45)
        {
            if(num>=1)
            cout<<" ";
            cout<<cj[i].name;
            num++;
        } 

我要回答