0
已解决
范杰然
新手守护
新手守护
https://ke.codingtang.com/#/problem/problemSub?id=1014
1014 整数序列元素的最值与最大跨度值经验值:800
题目描述 Description
给定一个长度为n的非负整数序列,求该序列的最大值与最小值,并计算其最大跨度值(最大跨度值=最大值-最小值)。
输入描述 Input Description
一共2行,第一行为序列的个数n(1 <= n <= 1000),第二行为序列的n个不超过1000的非负整数,整数之间以一个空格分隔。
输出描述 Output Description
输出一行,分别表示序列的最大值,最小值和最大跨度值,以一个空格分隔。
样例输入 Sample Input
8 8 9 7 5 7 3 1 4
样例输出 Sample Output
9 1 8
错误代码:
Wrong Answer:40分
#include<iostream>
using namespace std;
int main(){
int a=0,b=0,shu;
cin>>shu;
for(int i=1;i<=shu;i++){
int s;
cin>>s;
if(s>a){
a=s;
}
if(s<b){
if(i==1){
b=s;
}
else{
if(s<b){
b=s;
}
}
}
}
cout<<a<<" "<<b<<" "<<a-b;
return 0;
}
范杰然在2020-11-27 16:41:12追加了内容
哎,我的老帖子尽然火了。我随机采纳吧!(我都学到函数了)