问题标题: 我的程序哪里出错了?(题号1739坐标选点)

2
1
已解决
张梓沫
张梓沫
资深守护
资深守护

问题内容

题目描述 Description

有一个长方形,四个角的坐标分别是(2,-1),(2,1),(-1,-1),(-1,1)。写一个程序,判断一个给定的点(x,y)是否在这个长方形内(包括长方形边界),如果在正方形内输出“Yes”,否则输出“No”。

输入描述 Input Description

一行,点的坐标x、y,两个数字用空格隔开,x、y均为实数

输出描述 Output Description

Yes或者No

样例输入 Sample Input

1 1

样例输出 Sample Output

Yes

 

 

我编的程序

#include<iostream>
#include<cstdio>
#include<cmath>
#include<iomanip>
#include<cstring>
#include<string>
//#include<sstring>
using namespace std;
int main()
{
    int x,y;
    cin>>x>>y;
    if(x==2||x==-1&&y==-1||y==1)
        cout<<"Yes";
    else
        cout<<"No";
    return 0;
}

 

为什么是四十分?

 

各位大神,答案写简单一点

张梓沫在2018-02-02 21:50:04追加了内容

各位各位,为什么我试过了,却是60分?

#include<iostream>
#include<cstdio>
#include<cmath>
#include<iomanip>
#include<cstring>
#include<string>
//#include<sstring>
using namespace std;
int main()
{
    int x,y;
    cin>>x>>y;
    if(x<=2||x>=-1&&y==1||y>=-1)
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;
    return 0;
}

 

各位大神,再挑挑毛病好吗?


0
已采纳
芮奥运
芮奥运
高级光能
高级光能

我帮你看了数据  :测试点7

输入(显示前50行):

 

-1 -1.5

输出(显示前50行):

 

No

0
芮奥运
芮奥运
高级光能
高级光能

if(x <= 2 && x >= -1 && y <= 1 && y >= -1){

 

cout << "Yes" << endl;

 

0
0
朱宗晔
朱宗晔
初级光能
初级光能

核心部分 

if(x <= 2 && x >= -1 && y <= 1 && y >= -1){
        cout << "Yes" << endl; 
        return 0;
    }

 

0
陶梓锐
陶梓锐
新手光能
新手光能

  if(x==2||x==-1&&y==-1||y==1)
        cout<<"Yes";
    else
        cout<<"No";

有问题

0
臧启亚
臧启亚
初级光能
初级光能

核心代码:

if(a<=2&&a>= -1&& b<= 1&&b>= -1){
        cout << "Yes" << endl; 
        return 0;
    }

 

0
蒋智航
蒋智航
高级天翼
高级天翼

if(x <= 2 && x >= -1 && y <= 1 && y >= -1){

 

        cout << "Yes" << endl;

0
杨陈卓
杨陈卓
新手天翼
新手天翼

 if(x<=2||x>=-1&&y==1||y>=-1)

改成

if(x>=-1&&x<=2&&y>=-1&&y<=1)

 

我要回答