问题标题: 我的Dev-C++编译不了了

4
1
已解决
偶子睿
偶子睿
高级守护
高级守护

我的Dev-C++编译不了了。新建一个源代码,打好程序,但“编译”按钮是灰色的,按F9也不行。“编译运行”也按不了,只有“运行”可以,但会警告:“源文件未编译”。版本是5.11。系统是Windows 8。是系统问题吗?还是什么问题?谢谢!

偶子睿在2018-01-17 21:19:31追加了内容

贾老师给我发DevC++了,安装了还是不行。


1
已采纳
杨子逸
杨子逸
新手天翼
新手天翼

可以换一台电脑或找人重作一下系统

3
被禁言 贾敬波
贾敬波
高级守护
高级守护

我估计是你的Dev-c++程序被损坏了,你试试从网上重新下载一个安装一下吧。

2
王焜
王焜
新手守护
新手守护

Dev-c++程序被损坏了,你试试从网上重新下载一个安装一下吧

尝试一下按F11,如果还是不行的话,那就F11+Fn或者F9+Fn。

是不是用了2个编译运行

 

2
马佳滢
马佳滢
新手天翼
新手天翼

偶子睿 :

你的问题我也遇到过。只是我的“运行”警告:“找不到指定程序”。

我的方法:在Dev-C++上打好程序,在Visual c++上运行(有一点不好,此编程软件(Visual c++)不认long long int,不过有一招:

遇到long long int直接提交),我也用了半年(酷町堂老师建议重装系统),后来换了电脑。

注意:Visual c++是我们刚开始学习c++时老师叫我们安装的。

1
1
葛新
葛新
资深守护
资深守护

是不是安装360或者其他杀毒软件了?

0
黄俊博
黄俊博
资深光能
资深光能

版本运行不了?我遇到过,是版本不对。

0
黄俊博
黄俊博
资深光能
资深光能

版本运行不了?我遇到过,是版本不对。

0
0
0
0
詹子都
詹子都
新手光能
新手光能

是不是Dev-c++程序被损坏了???

0
詹子都
詹子都
新手光能
新手光能

尝试一下按F11,如果还是不行的话,那就F11+Fn或者F9+Fn如果还是不行,就重新下载

0
0
0
高亮节
高亮节
资深守护
资深守护

可能是后缀不是.cpp

不是.cpp文件不能编译

在保存代码的时候要注意

还有可能是win32系统与win64(x86)不兼容

建议换一下编译器。

0
朱苏婉
朱苏婉
中级守护
中级守护

我也遇到过,你试试关机重启,不行的话,再重新下载吧。

0
0
0
0
0
0
李伟宸
李伟宸
高级守护
高级守护

1. 关掉重开

2.重启电脑

3.重装电脑

4.升级**

5.(强烈推荐)下载一个6.5的Dev.C++

0
王若鸿
王若鸿
初级守护
初级守护

你是不是没有后缀.cpp?

0
余思成
余思成
高级守护
高级守护

删掉重下!!!!!!!

0
屠景瑞
屠景瑞
新手光能
新手光能

你从网上重新安装一下。

0
0
谈文瑞
谈文瑞
新手光能
新手光能

你从网上重新安装一下。

0
0
0
0
0
0
翟谦瑞
翟谦瑞
新手守护
新手守护

 

删了,重下!!!!!!!!!!!!

0
0
刘伯林
刘伯林
高级守护
高级守护

应该是.cpp的问题!!!

0
0
陶旭杰
陶旭杰
中级光能
中级光能

尝试一下按F11,如果还是不行的话,那就F11+Fn或者F9+Fn。

0
谢其桦
谢其桦
资深守护
资深守护

 在主页刷新一下,如果不行就多试几遍。

谢其桦在2018-01-15 13:05:18追加了内容

如果还是不行,就再下载一遍。

0
岳成浩
岳成浩
资深守护
资深守护

把代码删了,

重新搞。

0
周思睿
周思睿
新手光能
新手光能

Windows 8好像不能用5.11的Dev-C++,你升级一下c++试试。

0
0
0
贾智衡
贾智衡
高级守护
高级守护

ding!ding!ding!

挖坟!挖坟!挖坟!

0
0
任健睿
任健睿
中级守护
中级守护

可以找修电脑的人过来修一下,如果,你的电脑有问题的话,那就把旧的电脑卖了,再买新的电脑吧。

0
0
0
0
0
我要回答